1
Drupal VM 4 Is Here! With PHP 7.1 And Easy PHP Switching

Drupal is the open-source software popular for use in sites which contain blogs, portals, forums, e-commerce sites, information about individual and corporate entities, intranets, resource directories, social networking sites, etc. Written in  PHP, it is available in a ready-to-use format upon being downloaded. This software supports content management, podcasts, collaborative authoring, image galleries, newsletters and much more. Now, the newest and latest version of it is available on the net, seven whole months after PHP 7.0 and Ubuntu 16.04 were introduced by the VM 3 version of this Drupal software.  

Some of you might not be familiar with the concept of the Drupal VM. It is an instrument, or tool, built with the help of Vagrant and Ansible, that helps in the development of  Drupal environments.With the 4th installment in the series the Drupal tool is enhanced in terms of flexibility. You get a plethora of choices to pick from.  A few of the binaries are MySQL or PostgreSQL, Nginx or Apache, Redis or Memcached, and CentOS or Ubuntu.  Also, Drupal VM 4 is empowered with a seamless mode-switching power which allows the web developer to change the PHP mode in a fluid, no-hassle manner. The modes available are 5.6, 7.0 7.1. The best thing is that you can do this without having to recreate the whole development environment.

Here is a comprehensive list of the benefits that Drupal VM 4 would empower you with:

  • A really great aspect is that Drush is completely optional. You can choose to either use the version attached to the project or not use it at all. This is undoubtedly good news for web developers around the world.
  • As already mentioned before, Drupal VM 4 supports all three versions of the programming language PHP: 5.6, 7.0 and 7.1. All you need to do in order to activate the ‘smooth switch’ system is to do an update of the PHP version and run the Vagrant Provision. This easy PHP mode switching is apparently the real reason people are extremely excited about the recent update.
  • Another benefit is that you would now require the use of Vagrant 1.8.6 or later, VirtualBox 5.1.10 or later, and Ansible 2.2.0 or later. Of these, the latter is important only if it is installed on the host.
  • Although PHP 7.0 remains as the default, you’d be able to install the PHP 7.1 or 5.6 in a smooth movement (details mentioned in another point and also in the introduction).
  • You can work these changes on any Operating System, whether on a laptop or mobile.
  • Among other improvements, you can avail of the PHP upload_progress support, the optional DRUPALVM_ANSIBLE_ARGS support for the Ansible CLI options, and use the shallow Drush cones for the sake of building up environments faster. Drupal VM 4 has also added the GitHub ISSUE_TEMPLATE, fixed the Solr versioning error and set the composer.json to “VM” over “Project”.  A few bugs have been fixed; such as the #981, #1014, #1020, #1004 and #1037.

Awesome, isn’t it? And we have the exemplary efforts of Oskar Scholstrom and Thom Toogood to thank for it all!

Copyright © 2012 - 2017 CapitalNumbers Infotech Pvt Ltd. All Rights Reserved.